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Abstract— In this growing world, as civil engineer one needs 

to be fully aware of structural elements and the safety 

parameters before and during the execution of project. As an 

outcome to this an attempt has been made to learn the process 

of analysis and design of multistory building using Limit state 

method. This project focuses on Analysis and Design of 

Stadium. The design, using Limit State Method is taken up. 

In the limit state of collapse, the strength and stability of 

structure is ensured. The guidelines being followed are as per 

IS 456:2000 and IS 800:2007. The present project deals with 

the Analysis and Design of stadium of G+2 Floors proposed. 

All the structural elements are designed as per codal provision 

ETABS features contains powerful graphical interface with 

modeling, analytical, and design procedures. It is quick and 

very easy for simple structures. It can handle the largest and 

most complex building models. 

Keywords: Time History, Floor Displacement, Storey Drift, 

Base Shear, ETABS 2016 

I. INTRODUCTION 

The stadium is a covered or a not covered enclosed area, often 

circular or oval shaped, designed to showcase theatre, 

musical performances, or sporting events. It is composed of 

large open space surrounded on most or all sides by seating 

for spectators. The key feature of an indoor stadium is that the 

event space is the lowest point, allowing for maximum 

visibility. College indoor stadium is an important indicator to 

measure universities physical education, its function not only 

is required to meet college sports education , sports events 

undertaking, but also it should provide social services for 

mass sports activities development An  stadium is a group of 

sports facilities. The sports facilities are of indoor kind for 

e.g. table tennis, carom, chess, gymnasium etc. sports are the 

integral part of the student life so it is the essential 

requirement of good educational institution. It makes 

institution reputation higher and also increases the financial 

status. The design guide provides design principles to 

achieving an appropriately high quality stadium development 

that makes a positive contribution to the public environment 

The stadium sites is ideally suited for its intended 

use, being large, flat and also close enough to the city to be 

identified with its center and to facilitate excellent access to 

all modes of transport. Furthermore this site being close to the 

railway station, defining a major route into the city, provides 

an ideal setting for building that by virtue of its scale and 

function alone will become a major land mark and make a 

positive contribution to the urban form and image of the 

college. Indoor stadium solve all the problems and limitations 

inherent in outdoor stadium. You do not have to skip games 

because of the weather and you can play in comfort in a 

controlled environment. 

A. Etymology: 

"Stadium" is the Latin form of the Greek word "stadion", a 

measure of length equalling the length of 600 human feet. As 

feet are of variable length the exact length of a stadion 

depends on the exact length adopted for 1 foot at a given place 

and time. Although in modern terms 1 stadion = 600 ft (180 

m), in a given historical context it may actually signify a 

length up to 15% larger or smaller. 

The equivalent Roman measure, the stadium, had a 

similar length – about 185 m (607 ft) – but instead of being 

defined in feet was defined using the Roman standard passus 

to be a distance of 125 passūs (double-paces). 

The English use of stadium comes from the tiered 

infrastructure surrounding a Roman track of such length. 

Most dictionaries provide for both stadiums and stadia as 

valid English plurals. 

B. Advantages and Disadvantages of Stadium  

1) Advantages;  

Stadium supporters have provided a long list of reasons why 

it is a good idea, why everyone should support it and 

ultimately perhaps why it should receive some public 

funding. 

 There is the question of the economy – how it would 

create jobs, boosting tourism and other activities. 

 That it would provide a venue for other activities – 

sporting and cultural. 

 That it will benefits the sporting community. 

 The wider community would benefit with more people 

participating in sport. 

 It will lead to better more healthy lifestyles. 

 It would be a tonic to help us through these gloomy 

times. 

 The Pirates and Truro City would have a chance to move 

upwards (and onwards). 

 We would also get a conference centre and hotel. 

2) Disadvantages;  

A major disadvantage of renovating an existing stadium 

would be a team would have to find an alternative venue 

while their current one is being renovated (assuming moving 

to a more convenient location is not the reason for the move). 

An advantage would be that there's no need to buy or develop 

new land. There's also the potential drawback of certain fields 

cultivating appeal or character that fans might be concerned 

about losing (think Yankee Stadium). Apart from that it's hard 

to see how most of the reasons to build a bigger or more 

modern stadium (more seats, luxury boxes, etc.) would only 

be applicable to one or the other.  
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C. Objective and Scope   

1) Objective;  

The objective of the structural design is to plan a structure 

which meets the basic requirements. The project is to design 

an auditorium with a large span without compromising safety. 

 Safety: It’s has been the prime requirement of structural 

design and construction that a structure shall be so 

designed that it will not collapse in any way during its 

expected life span. 

 Strength and stability: Besides strength, ductility of 

structure is also nowadays considered to be an additional 

desired quality from a view point that if at all failure 

occurs, it should not be sudden but should give prior 

warning of its probable occurrence so as to enable one to 

minimize the consequences of collapse ad avoid loss of 

human life.  

 Economy: The economy shall be of material by optimum 

utilization of its strength or it may be the economy of cost 

of construction as well of cost of maintenance and 

repairs.  

 Aesthetic: The structure should not only be safe, durable 

but should also give a pleasing appearance.  

 Feasibility, practicable and Acceptability: The structure 

has to be so designed that the proposed solution is 

feasible, practicable and acceptable. 

Multi-purpose stadiums are a type of stadium 

designed to be easily used by multiple types of events. While 

any stadium could potentially host more than one type of 

sport or event, this concept usually refers to a specific design 

philosophy that stresses multi functionality over specificity. 

It is used most commonly in Canada and the United States, 

where the two most popular outdoor team sports – football 

and baseball – require radically different facilities. Football 

uses a rectangular field (Canadian football fields are larger 

than American ones), while baseball is played on a diamond 

and large outfield. This requires a particular design to 

accommodate both, usually an oval.  

D. Scope;  

In present study, an attempt has been made to study following 

aspects;  

1) Modeling of multistory structure outlines with and 

without gliding segment utilizing limited component 

programming, E-tabs.   

2) The section extents having diverse measurements are 

demonstrated from ground level to the upper storey level.  

3) Dynamic investigation is finished by Time History 

technique is yielded out for every one of the models.  

4) Comparative study is made for all frames. 

5) Study on the variations in the structural response due to 

the earthquake motions are tabulated.  

II. REVIEW OF LITERATURE  

1) Analysis & Design of sports complex using ETABS 

Sachin, Abhishek, Chethan (IJIRSET) The design 

process of structural planning and design requires not 

only imagination and conceptual thinking but also sound 

knowledge of science of structural engineering besides 

the knowledge of practical aspects. The purpose of 

standards is to ensure and enhance the safety, keeping 

careful balance between economy and safety. In the 

present study G+1 building is designed (Slabs, Beams, 

Columns and Footings) ETAB’s software. In order to 

design them, it is important to first obtain the plan of the 

particular building that is, positioning of the particular 

rooms, that they serve their respective purpose and also 

suiting to the requirement and comfort of the users. 

Thereby depending on the suitability; plan layout of 

beams and the position of columns are fixed. Thereafter, 

the loads are calculated namely the dead loads, which 

depend on the unit weight of the materials used 

(concrete, brick) and the live loads, which according to 

the code IS:456- 2000 and HYSD BARS Fe500 as per 

IS:875- 1987 part II. Safe bearing capacity of soil is 

adopted as 140KN/m2. 

2) Seismic Analysis of Indoor auditorium DilipanboseS, 

Aravindan S (JCEE) The project titled “Seismic analysis 

of Indoor Auditorium” has been taken up with an 

objective to determine the seismic response and behavior 

of an Auditorium constructed in Chennai area. Even 

though Chennai is considered as least prone to major 

earthquake, it is expected that a structure would survive 

major earthquakes without collapse that might occur 

unexpectedly during the life of the building. It should 

also be noted that after the Bhuj earthquake, Indian 

Standard IS: 1893 was revised and Chennai city was 

upgraded from zone II to zone III which leads to a 

substantial increase of the design ground motion 

parameters. Hence, this project presents an exploratory 

analysis of the seismic performance of multistorey 

buildings system built in the specified area with a 

comparative study of the structures under past major 

earthquakes.  

3) Seismic Analysis & design of multistory building using 

ETABS. Rinkesh R Bhandarkar, Utsav M 

Ratanpara(IJEDR) ETABS issue, for analysis and design 

for building systems. ETABS features are contain 

powerful graphical interface coupled with unmatched 

modeling, analytical, and design procedures, all 

integrated using a common database. It is quick and very 

easy for simple DESIGN AND ANALYSIS OF 

INDOOR STADIUM USING ETABS SOFTWARE 

2017-18 DEPARTMENT OF CIVIL ENGINEERING, 

SCE BANGALORE Page 11 structures. It can handle the 

largest and most complex building models. ETABS 

mainly offers following types of analysis: (a) Linear (b) 

Nonlinear (c) Pushover Analysis (d) P∆ Effect Analysis 

This program has been thoroughly tested and used in 

using the program.  

However, all the user accepts and understands that 

no warranty is expressed by the developers or the distributors 

on the accuracy or the reliability of the program. This 

program is a very useful tool for the design check of concrete 

structures. 

4) Design & analysis of Multistorey building under static & 

dynamic loading condition using ETABS Balaji UA, 

SelvarasanB(IJTRA) In this project a residential of G+13 

multi-story building is studied for earth quake loads 

using ETABS. .Assuming that material property is linear 

static and dynamic analysis are performed. These non-

linear analysis are carried out by considering severe 
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seismic zones and the behavior is assessed by taking 

types II soil condition. Different response like, 

displacements, base shear are plotted. 

III. METHOD OF ANALYSIS  

A. Linear Static;  

Linear analysis methods spring a clad proposition of flexible 

ability of the structures and specify where first resilient will 

rise. The linear static technique of analysis is limited to 

stunted, consistent buildings. Structural analysis is the 

method to evaluate a structural system to prediction its retorts 

and actions by using physical rules and mathematical 

calculation. The foremost detached of structural analysis is to 

govern core forces, stresses and deformation of structures 

under numerous load effect. Equivalent Lateral force 

technique is one in which all the lateral masses at each floor 

are planned substantially. Then the structure performance is 

recognized by smearing the lateral masses acting at every 

story in X and Y directions. These lateral loads are designed 

by bearing in notice the various factors comparable the 

Response reduction factor(R), Zone factor (Z), Importance 

factor (I), Horizontal acceleration coefficient (Ah), Structural 

response factor (Sa/g) and Total seismic weight of building 

(W) as per the IS code 1893-2002.  

B. Linear Dynamic;  

Dynamic analysis of structure is a part of structural analysis 

in which behavior of flexible structure subjected to dynamic 

loading is studied. Dynamic load always changes with time. 

Dynamic load comprises of wind, live load, earthquake load 

etc. Thus, in general we can say almost all the real-life 

problems can be studied dynamically. If dynamic loads 

changes gradually the structure’s response may be 

approximately calculated by a static analysis in which inertia 

forces can be neglected. But if the dynamic load changes 

quickly, the response must be determined with the help of 

dynamic analysis in which we cannot neglect inertial force 

which is equal to mass time of acceleration (Newton’s 2nd 

law).  

Mathematically F = M x a 

Where F is inertial force,  

Additionally, dynamic response (displacement and 

stresses) are generally far sophisticated than the compliant 

static shifts for similar loading amplitudes, particularly at 

booming situations. The actual physical structures have many 

numbers of displacements Therefore the utmost grave part of 

structural analysis is to create a computer model, with the 

predictable number of mass less member and finite number 

of shift of nodes which feigns the real behavior of structures. 

Another tough fragment of dynamic analysis is to analyze 

energy degeneracy and to boundary condition. So, it is very 

problematic to investigate structure for wind and seismic 

load. This exertion can be condensed using several 

programming systems. 

 
Fig. 3.1: Response Spectrum Curvature 

C. Response Spectrum Analysis;  

Response-spectrum analysis (RSA) is a linear-dynamic 

statistical analysis technique which pacts the stimulus from 

corresponding unusual approach of vibration to specify the 

likely maximum seismic response of a mainly elastic 

structure. Response-spectrum analysis contributes vision into 

dynamic comportment by measuring pseudo-spectral 

acceleration, velocity, or displacement as a utility of 

structural period for a specified time history and level of 

curbing. It is practical to wrap response spectra such that a 

smooth curve signifies the crowning response for every 

gratitude of structural period. Response-spectrum analysis is 

preferable for design decision-making as it relays structural 

type-selection to dynamic show. Response spectra aids to 

attain the topmost structural response under linear range, the 

figures. The plan dimension and height of each storey is kept 

same throughout the project in all models and present the data 

of all models in tabulated and line graph form. Model was 

made by using M-30 grade concrete and Fe500 grade rebar 

are used for Slabs, Beams, columns. Seismic zone factor is 

considered as 0.10 as it comes under zone II, response 

reduction factor is considered as 5. Importance factor is 

considered as 1.5 as per IS1893. Analysis Special Moment 

Resisting Frame type is carried out on G+2 STADIUM and 

typical storey height of. Rectangular Column of 660mm x 

660mm and Beam of 450mm x 900mm.Adopting slab 

thickness as 125mm and wall thickness as 200mm and shear 

wall thickness as 230mm.By considering all earthquake and 

wind load combination and it checked for same load 

combination as per IS codes. Loads such as live load, floor 

finish load, wall load are adopted as 3KN/m2, 1KN/m2 

and12.5KN/m2, respectively and dead load too is adopted as 

per IS 456; 2000.All other Earthquake loads as per IS 

1893.Unite weight of RCC and unite weight of masonry are 

30KN/m2 and 20 KN/m2 respectively. 

IV. DESCRIPTION OF STRUCTURE 

 
Fig. 4.1: Critical Section 
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Fig. 4.2:  3D view of structure 

V. MODELLING OF STRUCTURE  

A. Software Synopsis;  

Modeling tools and templates, code-based load prescriptions, 

analysis procedures and solution techniques, all coordinate 

with the grid-like geometry exclusive to this class of 

structure. Basic or radical systems under static or dynamic 

conditions may be assessed using ETABS. For a sophisticated 

assessment of seismic performance, modal and direct-

integration time-history investigates may couple with P-Delta 

and Large Displacement effects. Nonlinear links and 

concentrated PMM or fiber hinges may capture material 

nonlinearity under monotonic or hysteretic behavior. 

Intuitive and united sorts so buses of any complexity useful 

to appliance. ETABS categories persuasive and totally 

integrated basics for plan of equally steel and reinforced 

concrete structures. The program affords the manipulator 

with selections to generate, adapt, consider and plan 

structural models, all from within the similar operator 

interface. The program delivers cooperating atmosphere in 

which the operator can revise the stress conditions, sort 

appropriate deviations, such as revising member properties, 

and re-examine the results short of the essential to re-run the 

analysis. The yield in together graphical and tabulated 

presentations can be gladly printed. In this project seismic 

analysis of six dissimilar models is evaluated using E-

TABS2015. The assessments of outcomes are in terms of 

storey displacement, Storey drift, lateral forces, Fundamental 

Time period, storey shear, modes shapes etc.  

B. Procedure for Structural Modelling in ETABS is Given 

Below:  

1) STEP 1: LAYING OF MODEL WITH TEMPLATE   

Step: 1.1: 

Select Start New Model using Template and select “Use  

Built-In Settings with” and   select       

Display Units                 : Metric SI 

Steel Section Data Base    : Indian 

Steel Design Code  : IS 800:2007 

Concrete Design Code     : IS 456:2000 

 
Step 1.2: Enter the Grid and Story Dimensions in storey data 

sheet and click on Custom Grid Spacing then Click on Edit  

Grid Data 

 
Observing story and grid system data as shown in fig above; 

Plan Grid layout and 3D layout of model are created as shown 

in figure below; 

 
2) STEP 2: DEFINE MATERIAL PROPERTIES 

Step 2.1: Define >> Material Properties >> Add New 

Material  

Enter the details as shown in figure below for Concrete then 

click on “OK”. 

 
Step 2.2: 

Define >> Material Properties >> Add New Material  
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Enter the details as shown in figure below for Rebar then click 

on “OK”. 

 
3) STEP 3: DEFINE SECTION PROPERTIES  

Step 3.1: Defining of Beam Property 

Define >> Section Properties >> Frame Sections >> Add 

New Property 

 
Enter the Beam section properties as shown in figure 

below and click on “Modify/show Rebar” to enter 

reinforcement details for Beam as shown in figure below then 

click on “OK” 

 
Step 3.2: Define of Column Property 

Define >> Section Properties >> Frame Sections >> Add  

New Property 

 

Enter the Column section properties as shown in 

figure below and click on “Modify/show Rebar” to enter 

reinforcement details for Column as shown in figure below 

then click on “OK” 

 
Step 3.3: Define of Slab Property 

Define >> Section Properties >> Slab Sections >> Add New 

PropertySpecify slab section properties as shown in figure 

below; 

 
Step 3.4: Define of Shear wall: 

Define >> Section Properties >> Wall Sections >> Add New 

Property 

 
4) STEP 4: DRAWING OF COLUMNS /BEAMS 

/SLABS/ SHEAR WALL: 

Step 4.1: Placing & Orientation of Columns 

Draw >> Draw Beam/Column/Brace Objects >> Quick Draw 

Columns (Plan, 3D) 

Select the property type of column and place the columns 

where ever necessary according their Orientation, Properties,  

Shape as shown in below figure, 
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Placed columns extruded are shown below; 

 
Step 4.2: Drawing of Beam 

Draw >> Draw Beam/Column/Brace Objects >> Quick Draw 

Beams/Columns (Elev,Plan,3D) 

Select the property type of Beam and Place them where ever 

necessary according as shown in below figure 

Rendered view of critical section are shown in below figure: 

 
5) STEP 5:  DEFINING OF LOAD PATTERNS 

The Dead Load and Live Load are auto defined, if not define 

them and define Superimposed dead load as below Step: 

Defining of SIDL: 

Define >> Load Pattern >> SIDL >> Super Dead >>  

Multiplier “0” >> Add New Load >> Ok Step 5.1: Defining 

of Earthquake Loads: 

Step 5.1.1: Earthquake Load in X –Direction. 

Define >> Load Pattern >> EQX >> Seismic >> Multiplier  

“0” >>select Auto lateral Load as IS 1893 2002 >>Click on 

Add New Load >> Ok 

Select EQX >>Click on Modify Lateral Load Indirection& 

Eccentricity Box select only X-Direction and Deselect all 

Step 5.2: Earthquake Load in Y –Direction  

Define >> Load Pattern >> EQY >> Seismic >> Multiplier  

“0” >>select Auto lateral Load as IS 1893 2002 >>Click on 

Add New Load>> Ok 

Select EQY >>Click on Modify Lateral Load Indirection& 

Eccentricity Box select only Y-Direction and Deselect all 

 
6) STEP 6: MODEL ANALYSING 

Go to Analyze >>Select Set Load Cases To Run >> Run  

Now >> OK 

ANALYSIS 

S. No. NAME SIZE 

1 BEAM 450mm X900mm 

2 COLUMN 660mm X660mm 

3 SLAB 5000mmX15000mm 

4 R.C.C MATERIALS M 30 

5 GRADE OF STEEL FE 550 

6 
Truss section (double 

angle) 
110X110X10mm 

C. Plan Details 

TABLE 6.1.1: General details of the stadium 

 Different software used in completion of analysis and 

design: ETABS  2016, MS-OFFICE 2016 

1) Statement of project 

1. Utility of structure : Stadium 

2. Number of Stories : G+2 

3. 
Types of 

Construction 
: 

R.C.C. Framed 

Structure 

Truss section 

2) Materials 

1. 
Concrete mix for slabs 

Beams, Columns, Footings 
: M 30 

2. Main Steel : Fe 500 

3. Secondary Steel : Fe 500 

CHECK ANALYSIS >> check model >>select all >> ok  

See that are warning message is displayed 

D. Building Models Description 

1) MODEL 1: 

It is the bare frame model in which the weights of the masonry 

wall of 230mm thick have been assigned on all over the 

beams.  

The above procedure has been analyzed for Model 1. 

2) MODEL2:  

This model is same as Model 1 in addition the extreme corner 

columns of ground storey. 

The following procedure will analyze the Model 2:   

1) Open the ETABS Program  

2) Click the File menu >Open > MODEL 1  

3) Set the main window to Elevation View  

4) Remove the Corner Columns to Float from Base Story  

5) v) Select the Floating Columns > Assign > Frame > 

Releases/Partial Fixity >OK to assign fixed support  
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6) Go to Select > Object Type > Floors > Go to Define> 

Assign >Shell > Select Diaphragms >Select D1 >> 

Apply >> OK. 

7) Go to Analyze > Check Model 

8) Go to Analyze > Run  

9) Save the MODEL 1 file  to Save As (MODEL 2). 

 The following figures have been resultant from E-tabs 

 
SFD & BMD OF BEAM 

 
SFD & BMD OF COLUMN 

 
Fig. 5.1: 3D VIEW 

VI. RESULTS AND DISCUSSIONS 

A. General 

In this chapter we will debate around the outcomes which we 

attained from ETABS after evaluating the models and results 

have been specified in a tabular system and graphical 

illustration for well empathetic. 

 Shear force and bending moment diagrams 

 Wind forces impact 

 Story displacement graphs 

 
Shear force diagram 

 
Bending moment diagram 

 
SFD & BMD of total structure 

B. Story Displacement Graphs 

 
Wind load 
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Live load 

 
Dead load 

 
Wind load on structure 

 
Deformed shape of total structure 

 
WIND LOAD ON SLAB MEMBRANE 

VII. CONCLUSIONS 

1) Displacement analysis reveals that models with such a 

heavy beams and columns reduces in overall 

displacements when we compare with all other wind 

forces. Therefore consideration of wind analysis of the 

stadium shows maximum results as this displays that 

there is no much impact on heavy structure. 

2) When we study Model we conclude that the stadium are 

very much flexible in transferring the inertia forces 

generated by seismic loading also. 

3) When we study for base shear analysis we conclude that 

Model are showing nearly same responses. When we see 

Model the base shears are considered large enough. 

Therefore we could say that a vertical stiffener like core 

wall will impart huge resistant to wind resistance in turn 

improves the overall response. 

VIII. SCOPE FOR FUTURE STUDY 

1) The study can be extended for future works when the 

stadiums are situated in heavy windy areas in which the 

structure interaction can be done. 

2) It can also be extended for future work where the 

stadiums are situated in highly terrain areas. 

3) It can also be extended for non-linear seismic analysis 

such as time history & push over analysis in which 

overall performance of stadiums are predicted in a better 

sense. 
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